Error: Enabling vSAN Replication requires VMware Live Recovery license in VLR 9.0.5.1
search cancel

Error: Enabling vSAN Replication requires VMware Live Recovery license in VLR 9.0.5.1

book

Article ID: 447941

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • When configuring vSAN Data Protection's replication for a VM, the task fails with error:

    "Enabling vSAN Replication requires VMware Live Recovery license."

  • A valid subscription-based VMware Live Recovery license is applied in vCenter, but appears as "vCenter Site Recovery Manager Enterprise" with an expiry date of "Never":

Environment

  • VMware Live Recovery (VLR) 9.0.3, 9.0.4, 9.0.5, 9.0.5.1

  • VMware Protection and Recovery 9.1.0.0

Cause

Due to an issue in the Broadcom licensing tool, VLR subscription keys generated between April 20, 2026, and July 1, 2026, were produced without expiration dates, causing them to be misidentified as perpetual SRM keys.

Resolution

  • The issue with the Broadcom licensing tool has been fixed.

  • To resolve the license identification error:

    1. Ensure that VMware Live Recovery appliance is on version 9.0.5.1 if it was on 9.0.3, 9.0.4 or 9.0.5. See Download Broadcom products, patches and software to download this release.

      If Protection and Recovery appliance 9.1.0.0 was used, upgrade it to 9.1.0.0100.

    2. Split and merge the existing VLR license on the Broadcom Support Portal to regenerate the key with the correct expiry metadata.

    3. Add the new license key to the vCenter.

Additional Information