Users may experience random crashes of the EEM iGateway service. In some environments, this can occur multiple times a day (e.g., 2 to 14 times), causing disruptions in integrated applications such as Service Desk Manager (SDM), Service Catalog (SC), IT Asset Management (ITAM), and Process Automation (PAM).
Product: Embedded Entitlements Manager (EEM) / Service Management 17.x / PAM 4.4 CP04
Version: 12.6.x (including 12.6.6 and 12.6.7)
Component: iGateway
The root cause may be external environmental factors (WAF, AV, etc) or memory management issues within the iGateway process that persist even after increasing Java heap settings (Xmx) or applying standard configurations in the igateway.conf
If standard configuration and memory adjustments do not resolve the random crashes, implementing a High-Availability (Failover) configuration by adding a secondary EEM server to the cluster is recommended.
Install the same EEM version from primary EEM server in a clean secondary server.
Follow the official documentation to add the secondary server to the primary server's cluster.
How to Set Up a Failover Environment
Note: There is demo with the same steps from the link above in the following link: CA EEM High-Availability Configuration on Windows
Once the EEM cluster is healthy, update integrated products to point to both EEM nodes:
server1,server2). Configuring two EEM servers in failover for Service CatalogNX_EIAM_HOSTNAME in Options Manager to include both nodes (e.g., server1,server2). EE_AUTHFAILED error trying to log into SDM with EEM setup for failover