Upgrade of VMware Identity Broker from 9.0.2 to 9.1.0 fails with error "Prepare Postgres Migration"
search cancel

Upgrade of VMware Identity Broker from 9.0.2 to 9.1.0 fails with error "Prepare Postgres Migration"

book

Article ID: 447871

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

When upgrading VMware Identity Broker (vIDB) from version 9.0.2 to 9.1.0, the upgrade workflow halts during the "Perform Component Upgrade" sequence. The task times out after approximately 12 to 15 minutes with the error: "Prepare Postgres Migration. Status: Failed."

Environment

VMware Identity Broker 9.1

Cause

This issue occurs because the archive_mode parameter on a database replica pod (such as vidb-postgres-instance-1) is stuck in an off state. During the upgrade task, the automation sequence attempts to change the archive mode status to on but fails, resulting in a timeout that fails the entire upgrade process.

Resolution

This issue is under review with Broadcom Engineering and is slated to be fixed in a future release. Please subscribe to this article to be updated on the fix status refer to Subscribe to a Broadcom knowledge article by article or product 

Workaround:

To successfully bypass this issue and complete the upgrade, ensure that the primary vidb-postgres-instance-0 is the elected leader to prevent switchovers during the shutdown process:

  1. SSH to the vIDB appliance as vmware-system-user and run sudo -i to switch to the root user.
  2. Verify the current leader of the Postgres cluster by running: :
    kubectl exec #### -n vidb-external -- patronictl list
  3. If the node is not the active leader, switch the leader to the primary instance (e.g., ####) by running: 
    Note: Update vidb-postgres-instance-x with the current leader.
    kubectl exec -it #### -n vidb-external -- patronictl switchover --leader #### --candidate #### --force
  4. Once the leader is set, verify the archive state by running: 
    kubectl exec -it #### -n #### -- psql -U postgres -c "SHOW archive_mode; SHOW archive_command; SHOW archive_status;"
  5. Resume or retry the upgrade workflow from the VCF Operations UI.

Additional Information

  • To verify the current archive configuration on VIDB appliance 9.0.x version, run the following command:
    kubectl exec -it <postgres-pod> -n <namespace> -- psql -U postgres -c "SHOW archive_mode; SHOW archive_command; SHOW archive_status;"