After assigning the whole folder structure to another user other than root post installation of Dollar Universe Explorer, the product fails to start.
When attempting to start the instance, the unistartdux script terminates with the following error: => This Dollar Universe Explorer instance can only be started by instance owner or "root" user.
Investigation reveals that the RUNNING_PID file cannot be created in the duexplorer/bin directory due to the permissions being set to 555 during installation.
The DUX installation sets the permissions of the bin directory to 555 (read and execute only). This prevents the non-root owner from writing the RUNNING_PID file or other tracking metadata (e.g., es_uvms_fields_updated_do_not_touch) to that directory during the startup sequence.
Grant write permissions to the instance owner for the bin directory.
root user or a user with sudo privileges.bin directory to 755: chmod 755 binadmindu) can now create files in the bin folder.unistartdux script.Fix Status: This issue is confirmed as a product limitation (tracked via DE208159).
To receive updates on the fix status, .
For further details on running Dollar Universe components as a non-root user, see .