Error: Host is not configured with supported network device on Bare Metal NSX Edge with Broadcom BCM57414 NIC
search cancel

Error: Host is not configured with supported network device on Bare Metal NSX Edge with Broadcom BCM57414 NIC

book

Article ID: 447820

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • When attempting to install a VMware NSX Bare Metal NSX Edge node on a server equipped with Broadcom BCM57414 network adapters (e.g., Lenovo SR650 V4), the installation fails.
  • The console displays the following error messages:
    • "Host is not configured with supported network device"
    • "No Linux drivers" (specifically failing to bind the NICs to the data plane)

Environment

  • VMware NSX 4.2.x
  • Bare Metal Edge Node
  • Broadcom BCM57414 NIC 

Cause

The Broadcom BCM57414 network interface card is not supported for use with the NSX Data Plane in the NSX 4.2.x and 9.0.x release branch. The required drivers to bind these interfaces to the DPDK-based fastpath are not present in the 4.2.x and 9.0.x installer image.

Resolution

Fixed in VMware NSX 9.1 and higher. See Download Broadcom products and software for steps to download this release.

For environments running NSX 4.2.x or 9.0.x where an upgrade to 9.1 is not immediately possible, the following workaround is required:

  1. Hardware Replacement: Replace the Broadcom BCM57414 NICs with a supported model, such as the Intel E810 or Mellanox ConnectX-6, as listed in the NSX Edge Bare Metal System Requirements.

Additional Information

For instructions on submitting a feature request for other hardware considerations, refer to Submit a VMware by Broadcom feature request.