Aria Automation, Identity Manager (vIDM), or Suite Lifecycle nodes migrated to a new network/vCenter using HCX may fail to start services or prevent IP address modifications. This occurs because vApp options are not preserved during HCX migration.
/opt/vmware/etc/vami/ovfEnv.xml file is missing or lacks network configuration.HCX migration (Bulk, vMotion, or RAV) does not support the migration of vApp configurations/options for VMware software appliances. When these appliances are moved to a new vCenter, the network metadata required for service initialization is lost.
To manually restore services on existing versions, perform these steps in the specific order of LCM -> vIDM -> vRA:
/opt/vmware/etc/vami/ovfEnv.xml.horizon-workspace service and verify the /etc/hosts file contains the correct master IP./opt/vmware/etc/vami/ovfEnv.xml.kubectl get pods -A -wFor defects and enhancements, subscribe to this article (reference: ) to be updated on fix status.