Precheck failures block the VMware Cloud Foundation (VCF) SDDC upgrade process when the NSX host status displays as Unknown in the NSX UI. SDDC prechecks fail with the specific error message: NSX audit not connected transport nodes validator failed. This article provides steps to resolve this state caused by opsagent communication failures
StreamConnection[... Closed to tcp://127.0.0.1:9100 sid:-1] Closed (reason: network error, error: 32-Broken pipe)The NSX opsagent service on the ESXi host experiences an internal communication failure due to a broken pipe connection on the local socket (port 9100). The nsx-syslog.log from the affected ESXi host typically shows the following:
StreamConnection[... Closed to tcp://127.0.0.1:9100 sid:-1] Closed (reason: network error, error: 32-Broken pipe)
Because this agent reports and updates the host's health status to the NSX Manager, the communication breakdown results in an Unknown host status, triggering the transport node validator failure.
Maintenance Mode.9100.Up in the NSX UI.To gather a support bundle from the ESXi host, see Collecting diagnostic information for VMware ESXi using vSphere Client
If you require further assistance, see Contact Broadcom support to speak with a Support Engineer.