{"level":"error","message":"Failed to get cluster for datastore native snapshot capability check","error":"DB record not found"}
snap-service.log. {"level":"info","timestamp":"2026-06-25T08:49:38.701Z","C":"capability/local_datastore_capability_service.go:87","message":"Datastore capability check result","opID":"6a3b4961","datastoreMoId":"datastore-33","siteId":"eada4c1f-c145-4178-a16a-####","capability":"snapshot","hasCapability":false}
VCF Automation 9.1.x
VMware Live Recovery 9.1.x
vSAN ESA 9.1 with Compute-only cluster configuration.
The pairing option is disabled due to an unsupported storage configuration. This occurs when the target site uses a "Compute only cluster - vSAN" that points to a remote vSAN datastore identical to the primary site's datastore. This prevents the system from identifying local native snapshot capabilities required for pairing.
Sharing the same vSAN Datastore as the source site with the target site is an unsupported configuration.
vSAN Compute Cluster Purpose-built vSphere cluster optimized to consume storage from vSAN storage cluster or vSAN HCI cluster.
/var/log/vmware/snapservice/snap-service.log on Data Protection Appliance, the below events would show up for compatibility./var/log/vmware/snapservice/snap-service.log:
snap-service.log.2:{"level":"info","timestamp":"2026-06-25T08:49:38.701Z","C":"capability/local_datastore_capability_service.go:87","message":"Datastore capability check result","opID":"6a3b4961","datastoreMoId":"datastore-33","siteId":"eada4c1f-c145-4178-a16a-####","capability":"snapshot","hasCapability":false}
{"level":"info","timestamp":"2026-06-28T12:10:46.937Z","C":"vcenter/configuration.go:109","message":"Cannot determine whether cluster has NativeSnapshot capability for cluster.","opID":"6a3f5f24","cluster":"domain-c9","err":"DB record not found Failed during DB operation record not found"}
{"level":"error","timestamp":"2026-06-28T11:58:46.928Z","C":"capability/local_datastore_capability_service.go:113","message":"Failed to get cluster for datastore native snapshot capability check","opID":"6a3f5df6","datastoreMoId":"datastore-1600","siteId":"07259f92-60d6-47f9-ab3f-####","error":"DB record not found Failed during DB operation record not found"
Verify if the target cluster is configured as a Compute Cluster - vSAN.
Ensure the target site utilized a vSAN datastore that is different from the primary site vSAN datastore.
If using non-vSAN storage (e.g., NFS), disable the compute-only vSAN cluster setting.
Migrate virtual machines out of the remote datastore before unmounting or changing configurations.
For further assistance, Contact Broadcom Support.