Error: Failed to bootstrap VCF services runtime during VCF 9.0.x to 9.1 upgrade
search cancel

Error: Failed to bootstrap VCF services runtime during VCF 9.0.x to 9.1 upgrade

book

Article ID: 446929

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • During a VMware Cloud Foundation (VCF) upgrade from version 9.0 to 9.1, the "Deploy VCF Management Components" step fails during the "Bootstrap VCF service platform" runtime task.

Symptoms

  • The SDDC Manager UI displays error: java.lang.StringIndexOutOfBoundsException: Range [-1, 0) out of bounds for length 0.
  • The following entries were observed in /var/log/vmware/vcf/domainmanager/domainmanager.log in SDDC Manager: 

    LocalProcess ERROR: YYYY-MM-DD HH:MM:SS - Error: error while validating VC resources: failed to convert datastore: failed to convert MoID Datastore:datastore-#### to path: ServerFaultCode: The object 'vim.Datastore:datastore-Moid' has already been deleted or has not been completely created
    LocalProcess ERROR: YYYY-MM-DD HH:MM:SS - YYYY-MM-DD HH:MM:SS error: error while validating VC resources: failed to convert datastore: failed to convert MoID Datastore:datastore-#### to path: ServerFaultCode: The object 'vim.Datastore:datastore-Moid' has already been deleted or has not been completely created
    ::::::::
    YYYY-MM-DD HH:MM:SS error: failed to find bootstrap VM 'bootstrap-vm-#####': failed to find VM /Datastore_name/vm/vcf-management-services/bootstrap-vm-#####:
     vm '/Datastore_name/vm/vcf-management-services/bootstrap-vm-#####' not found
    YYYY-MM-DD HH:MM:SS ERROR [vcf_dm,6a4#######a397,aa1c] [c.v.e.s.o.model.error.ErrorFactory,dm-exec]  [#####]  Failed to bootstrap VCF services runtime
    com.vmware.evo.sddc.orchestrator.exceptions.OrchTaskException: Failed to bootstrap VCF services runtime
            at com.vmware.vcf.vimanager.fsm.actions.BootstrapVspClusterAction.execute(BootstrapVspClusterAction.java:218)
            at com.vmware.vcf.vimanager.fsm.actions.BootstrapVspClusterAction.execute(BootstrapVspClusterAction.java:89)
            at com.vmware.evo.sddc.orchestrator.platform.action.FsmActionState.invoke(FsmActionState.java:66)
            at com.vmware.evo.sddc.orchestrator.platform.action.FsmActionPlugin.invoke(FsmActionPlugin.java:161)
            at com.vmware.evo.sddc.orchestrator.platform.action.FsmActionPlugin.invoke(FsmActionPlugin.java:147)
            at com.vmware.evo.sddc.orchestrator.core.ProcessingTaskSubscriber.invokeMethod(ProcessingTaskSubscriber.java:401)
            at com.vmware.evo.sddc.orchestrator.core.ProcessingTaskSubscriber.processTask(ProcessingTaskSubscriber.java:515)
            at com.vmware.evo.sddc.orchestrator.core.ProcessingTaskSubscriber.accept(ProcessingTaskSubscriber.java:128)
            at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(DirectMethodHandleAccessor.java:103)
            at java.base/java.lang.reflect.Method.invoke(Method.java:580)
            at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:85)
            at com.google.common.eventbus.Subscriber.lambda$dispatchEvent$0(Subscriber.java:71)
            at com.vmware.vcf.common.tracing.TraceRunnable.run(TraceRunnable.java:63)
            at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144)
            at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642)
            at java.base/java.lang.Thread.run(Thread.java:1583)
    Caused by: java.lang.RuntimeException: java.lang.StringIndexOutOfBoundsException: Range [-1, 0) out of bounds for length 0
            at com.vmware.vcf.vimanager.services.VspServiceImpl.bootstrapVspCluster(VspServiceImpl.java:237)
            at com.vmware.vcf.vimanager.fsm.actions.BootstrapVspClusterAction.execute(BootstrapVspClusterAction.java:185)



Environment

VMware Cloud Foundation (VCF) 9.x

Cause

The issue occurs because VCF components were migrated between datastores, leaving a stale Managed Object ID (MOID) for the old datastore in the SDDC Manager database.

During deployment, the workflow attempts to cross-reference this MOID between SDDC Manager and the vCenter inventory. Because the old MOID no longer exists in vCenter, the deployment fails due to the mismatch.

Resolution

Fixing this value requires manual updates to the SDDC Manager database. Open a request with Broadcom Support to perform the necessary database modifications.