Password rotation for the Management Domain vCenter Single Sign-On (SSO) account initiated via VCF SDDC Manager fails.
Failed to update NSXT Compute Manager details
/var/log/vmware/vcf/operationsmanager/operationsmanager.log, the following exception is recorded:Exception Thrown: NsxtManagerSsoUpdater class threw a PasswordUpdateException. Failed to update NSXT Compute Manager details : { "error_code" : 7055, "module_name" : "inventory-mgmt", "error_message" : "For the compute manager with id, either the FQDN/IP address or credentials are invalid." }`This issue is caused by a database inconsistency, where the dedicated NSX Compute Manager service account (e.g.,svc-nsx-manager...) exists within the vCenter Server SSO directory, but is missing from the SDDC Manager PostgreSQL database (platform database).
Because SDDC Manager lacks the inventory record for this specific account, it cannot map the updated credentials to the NSX Compute Manager during the rotation workflow, leading to an API rejection from NSX.
To resolve this issue, an update needs to be made to the SDDC Manager platform database.
Contact Broadcom Support referencing this article to receive assistance with the required steps.