VCF SDDC Manager SSO Password Rotation fails with NSX Compute Manager Error 7055 due to missing NSX SVC account
search cancel

VCF SDDC Manager SSO Password Rotation fails with NSX Compute Manager Error 7055 due to missing NSX SVC account

book

Article ID: 444454

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

Password rotation for the Management Domain vCenter Single Sign-On (SSO) account initiated via VCF SDDC Manager fails.

  • The task status in SDDC Manager shows as Failed.
  • The following error is observed in the UI:
    Failed to update NSXT Compute Manager details
  • In /var/log/vmware/vcf/operationsmanager/operationsmanager.log, the following exception is recorded:
    Exception Thrown: NsxtManagerSsoUpdater class threw a PasswordUpdateException. Failed to update NSXT Compute Manager details : { "error_code" : 7055, "module_name" : "inventory-mgmt", "error_message" : "For the compute manager with id, either the FQDN/IP address or credentials are invalid." }`

Environment

  • VCF Operations 9.x
  • SDDC Manager 9.x
  • vCenter 9.x

Cause

This issue is caused by a database inconsistency, where the dedicated NSX Compute Manager service account (e.g.,svc-nsx-manager...) exists within the vCenter Server SSO directory, but is missing from the SDDC Manager PostgreSQL database (platform database).
Because SDDC Manager lacks the inventory record for this specific account, it cannot map the updated credentials to the NSX Compute Manager during the rotation workflow, leading to an API rejection from NSX.

Resolution

To resolve this issue, an update needs to be made to the SDDC Manager platform database.
Contact Broadcom Support referencing this article to receive assistance with the required steps.