SDDC Manager pre-upgrade check fails with NullPointerException: Psc.getDomainId() is null
search cancel

SDDC Manager pre-upgrade check fails with NullPointerException: Psc.getDomainId() is null

book

Article ID: 444337

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

When attempting to run pre-upgrade checks or health assessments in VMware Cloud Foundation (VCF) via SDDC Manager or the Fleet Management UI, the task fails immediately.

  • The UI may display a generic error: Http failure response for https://<VCF-operation_FQDN>/vcf-operations/plug/sddc-108/plugin/api/v1/system/check-sets: 500 OK
  • We see the domainName: UNKNOWN and domainID :"" as null  for the vCenter server in  /var/log/vmware/vcf/operationsmanager/operationsmanager.log
    • YYYY:MM:DDTHH:MM:SEC:Z166), CredentialValidationOperationEntity(validationId=######-####-####-#####-########, credentialId=#########-####-####-####-###########, entity={"entityId":"#########-####-####-####-###########","entityFqdn":"vc-FQDN","entityType":"PSC","entityVersion":"8.0.3.00800-25197330","credentialId":"#######-####-####-####-###########","credentialType":"SSO","username":"[email protected]","domainName":"<Domain_name>","domainId":"#########-####-####-####-##########","creationTime":############,"modificationTime":############,"accountType":"SYSTEM"}, response={"resultStatus":"SUCCEEDED","entityName":"<vCenter_FQDN>","entityId":"#########-####-#####-####-#########","entityType":"PSC","domainName":"<Domain_name","credentialType":"SSO","credentialId":"########-####-####-####-#########","username":"[email protected]","passwordValidityStatus":"VALID","passwordExpiryDataRetrievalStatus":"SUCCEEDED","noOfDaysToExpiry":99999,"creationTime":"Month Date, YYYY, HH:MM:SEC","completionTime":"Month DD,YYYY , HH:MM:SEC:"}, status=SUCCEEDED, creationTime=YYYY:MM:DDTHH:MM:SEC:Z166, completionTime=YYYY:MM:DDTHH:MM:SEC:Z166), CredentialValidationOperationEntity(validationId=########-90f3-42fe-a580-#########, credentialId=########-####-####-####-###########, entity={"entityId":"########-####-####-####-#############","entityFqdn":"vcf_ops_FQDN","entityType":"PSC","entityVersion":"8.0.3.00000-24022515","credentialId":"##########-####-####-####-##########","credentialType":"SSO","username":"[email protected]","domainName":"UNKNOWN","domainId":"","creationTime":############,"modificationTime":############,"accountType":"SYSTEM"}, response={"resultStatus":"FAILED","entityName":"<vcf_ops_FQDN>","entityId":"#######-####-####-####-##########","entityType":"PSC","domainName":"UNKNOWN","credentialType":"SSO",
  • The failure occurs during the inventory sweep or discovery phase before any actual tests begin.

Environment

 VCF operation 9.0.x

Cause

The issue is caused by an orphaned or duplicate Platform Services Controller (PSC) record in the SDDC Manager PostgreSQL database. During the discovery process, the Operations Manager queries the database for PSC products. If it encounters a record that lacks an associated Domain ID, the assessment process crashes because it cannot perform the required string comparison on a null value.

Resolution

The SDDC Manager Database needs to be updated where the  duplicate ID associated with the vCenter server has to be deleted.

For assistance with this issue, contact support.