After upgrading to VMware Cloud Foundation (VCF) 9.1, database backups for the Identity Broker (VIDB) component fail with the error: “Database backup could not be completed for component vidb; please retry the operation or contact support if the issue continues.”
Users are unable to log into any VCF component using VCF SSO. The login attempts fail globally with the error message: general.login.error.
Configure VCF SSO" page appears completely blank when navigating to Manage > Identity & Access > VCF SSO Overview in VMware Cloud Foundation OperationsFleet Lifecycle service pod logs shows below error:
/services-logs/vcf-fleet-lcm/###-otg-#####-4xb7d/vcf-fleet-build-service-fleetbuild-#######-#####/fleetbuild/console-log-####.log
stdout F YYYY-MM-DDTHH:MM:SS ERROR Fleet Build 55 [lcm@4413 scPath="ops" thread="system-task-worker-24" logger="c.b.v.l.t.o.s.step.StepMessageHelper" method="appendRefCode:L"] [, taskId=#####-#####-####-####]- (EC399588) (com.broadcom.vcf.lcm.SddcLcmClientTaskFailed) Task with ID 'YYYY-MM-DDTHH:MM:SS#####-#####-####-####' from SDDC lifecycle with ID '#######-####-####-###-########' has completed with failure(s). Check the errors in the next sub-task(s) for more details.
stdout F YYYY-MM-DDTHH:MM:SS INFO Fleet Build 55 [lcm@4413 scPath="ops" thread="system-task-worker-24" logger="c.n.c.c.execution.WorkflowExecutor" method="decide:L"] [] - Execution terminated of workflow: BACKUP_AND_RESTORE_WORKFLOW.1/######-e71f-####-83eb-#######.RUNNINGYYYY-MM-DDTHH:MM:SS
Based on the SDDC Lifecycle logs, it was observed that the backup operation is failing for the VIDB database.
/services-logs/vcf-sddc-lcm/###-otg-####-4xb7d/vcf-sddc-build-service-sddcbuild-#######-####/sddcbuild/console-log-######.log
stdout F YYYY-MM-DDTHH:MM:SS ERROR sddc-build-service 54 [lcm@4413 scPath="ops" thread="system-task-worker-17" logger="c.b.v.l.t.o.s.step.StepMessageHelper" method="logTaskMessage:96"] [YYYY-MM-DDTHH:MM:SS#####-#####-####-####, taskId=#####-#####-####-####] - Database backup failed for component vidb. Please retry the operation or contact support if the issue persists.
stdout F YYYY-MM-DDTHH:MM:SS ERROR sddc-build-service 54 [lcm@4413 scPath="ops" thread="system-task-worker-17" logger="c.b.v.l.t.o.s.step.StepMessageHelper" method="appendRefCode:125"] [YYYY-MM-DDTHH:MM:SS#####-#####-####-####, taskId=#####-#####-####-####] - (########) (com.broadcom.vcf.lcm.VspTaskMessage) Backup workflow failed for component: vidb
Identity Broker service pod logs shows below error :
/services-logs/vidb-external/##-otg-####-2scns/pg-backup-vidb-postgres-instance-backup-####-##-##-##-##-#####/backup-container/console-log-########.log
stdout F Executing on-demand WAL backup command in target pod ...YYYY-MM-DDTHH:MM:SS stdout F Master pod identified as vidb-postgres-instance-1 is RunningYYYY-MM-DDTHH:MM:SS stdout F Backup output: curl: (60) SSL: no alternative certificate subject name matches target hostname 'pgbackup-vidb-postgres-instance.vidb-external.svc.cluster.local'YYYY-MM-DDTHH:MM:SS
The failure is caused by a missing Subject Alternative Name (SAN) entry for pgbackup-vidb-postgres-instance.vidb-external.svc.cluster.local in the Postgres certificate used by the Identity Broker.
Broadcom Engineering team is aware of this issue, and a fix is planned for an upcoming release.
As a workaround, regenerate the PostgreSQL certificate secret to include the missing Subject Alternative Name (SAN) entry.
kubectl get certificaterequest -n vidb-external -o yamlkubectl delete secret vidb-postgres-instance-postgres-cert-secret -n vidb-externalNote : If step 2 fails, delete any restored certificate requests with the following command:kubectl delete certificaterequest -n vidb-external -l velero.io/restore-name=vidb-restore-phase6kubectl exec -c postgres vidb-postgres-instance-0 -n vidb-external -- cat /tls/tls.crt | openssl x509 -noout -textpgbackup-vidb-postgres-instance.vidb-external.svc.cluster.local is now present in the Subject Alternative Names (SANs) section of the output.