Invalid license key error when applying the SRM license key
search cancel

Invalid license key error when applying the SRM license key

book

Article ID: 441685

calendar_today

Updated On:

Products

VMware Site Recovery Manager VMware Live Recovery

Issue/Introduction

Assigning the Site Recovery Manager license key on the vSphere Web Client, the UI displays the error message as Invalid license key.

Environment

  • VMware Live Recovery
  • VMware Live Site Recovery
  • Site Recovery Manager
  • VMware Cloud Director Avalaibility 

Cause

Change in the Broadcom licensing system to address Term based data protection license incorrectly provisioned causes the license key to be not recognized

Resolution

The issue is resolved in the newly release versions of vLSR, SRM and vCDA

  • Upgrade or Patch SRM/VCDA:
  1. vLSR/SRM versions 9.0.0 through 9.0.2.3 must upgrade to 9.0.2.4 or later.
  2. vLSR/SRM versions 9.0.3, 9.0.4, or 9.0.5 must upgrade to 9.0.5.1 or later.
  3. vCDA version 4.7.4 must upgrade to 4.7.5 or later.

Note: This is mandatory to ensure the product correctly recognizes the new license definition, whether the original key was issued in error or the customer is renewing/expanding an existing deployment.

If you continue to receive the error after upgrading the SRM versions to 9.0.2.4 or 9.0.5.1, recommended to perform the license action of split and merge of SRM license key, so that a new license key generated will resolve the issue.

Additional Information

VMware Live Site Recovery 9.0.2.4 Release Notes