HCX Service Integration Accounts and customer-defined password expiration in VMC on AWS
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HCX Service Integration Accounts and customer-defined password expiration in VMC on AWS

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Article ID: 440345

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

You are planning to implement security hardening or password rotation policies for the [email protected] account.

You may seek to:

  • Change the user account used for HCX-to-vCenter or HCX-to-NSX integration.
  • Transition HCX system integration to use Active Directory (AD) service accounts.

Environment

  • VMware Cloud (VMC) on AWS
  • VMware HCX

Cause

There is a common misunderstanding that HCX utilizes the customer-accessible [email protected] account for its background integration with SDDC management components (vCenter and NSX).

Resolution

No action or reconfiguration is required.

In the VMware Cloud on AWS service, the integration between HCX and the SDDC management plane is managed automatically by the service provider.
HCX uses internal, system-managed accounts to communicate with vCenter and NSX. These accounts are not subject to customer-defined password expiration or lockout policies.

Additional Information