vSAN Cluster Shutdown Wizard Blocked by Physical Disk Failure
search cancel

vSAN Cluster Shutdown Wizard Blocked by Physical Disk Failure

book

Article ID: 440146

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

When attempting to use the vSAN Cluster Shutdown wizard, the process is blocked during the pre-check phase. The following symptoms may be observed:

  • The Operational Health pre-check returns a red error status.
  • The Shutdown button is greyed out and cannot be selected.
  • vSAN Skyline Health reports a status of AbsentImpending Permanent Disk Failure, or Unhealthy for one or more physical disks.

Environment

VMware vSAN 8.x

VMware vSAN 9.x

Cause

The vSAN Cluster Shutdown wizard requires all hosts and storage devices to be in a "Healthy" operational state to ensure data integrity during the power-off sequence. A failed disk or a failed disk group (e.g., due to a cache tier failure or deduplication dependencies),  prevents the wizard from verifying that all objects are safe and fully synced.

Resolution

To unblock the shutdown wizard, the unhealthy disk or disk group must be remediated or removed.

1. Identify the Faulty Component

  • Navigate to Monitor > vSAN > Skyline Health.
  • Expand the Physical Disk category and review the Operation Health for each host.
  • Identify the specific host and Disk ID (NAA) reporting an unhealthy state.

2. Remediate the Disk Group

  • For OSA Clusters: If a capacity disk has failed, remove the disk from the group. If the cache disk has failed, or if Deduplication and Compression is enabled, you must remove the entire disk group.
  • Physically Replace Hardware: If the disk is physically dead (Absent), replace the drive in the server chassis.
  • Rebuild: Add the new disk back to the disk group and wait for the Resyncing Objects task to complete.

3. Verification and Shutdown

  • Once all disks show a Healthy status in Skyline Health, re-run the Shutdown Cluster wizard pre-checks.
  • After the pre-checks pass with green status, proceed with the cluster shutdown.

Additional Information

Shut Down the vSAN Cluster Using the Shutdown Cluster Wizard

How to remove a failed disk from a vSAN disk group/host 

Unable to delete absent Disk with UUID via vSphere UI or command line