Error "The resource vim.dvs.DistributedVirtualPort is not available" during Live Site Recovery test
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Error "The resource vim.dvs.DistributedVirtualPort is not available" during Live Site Recovery test

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Article ID: 439941

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

During a test recovery in VMware Live Site Recovery the operation fails for specific virtual machines. You see the following error message in the Recovery Plan:

The resource vim.dvs.DistributedVirtualPort is not available in vim.dvs.DistributedVirtualPortgroup ####

Some VMs will show up in the Distributed Port group while others may not. 

vmware-dr.log on Recovery site Live Site Recovery appliance has the follow error regarding the test failure:

No free port is available in Distributed Port Group ######

Environment

Live Site Recovery 9.x (all versions)

Cause

The Distributed Port Group on the recovery site has a fixed number of ports that is insufficient for the total number of virtual machines attempting to connect during the test. Even if the port group is set to Elastic allocation, the baseline number of ports must be large enough to accommodate the connects the VMs make if vCenter cannot expand the group fast enough or the maximum limit has been reached. 

Resolution

The affected port group will need to be manually increased on the recovery site:

  1. Log in to the vSphere Client on the recovery site
  2. Navigate to Inventory and Select "Networking"
  3. Locate and right-click the Distributed Port Group mentioned in the error message in vmware-dr.log
  4. Select "Edit Settings"
  5. Under the General section, increase the number of ports to a value that exceeds the total number of virtual machines expected to use this network during a recover or test (e.g., increase from 10 to 64)
  6. Ensure "Port Allocation" is set to "Elastic" for future dynamic growth.
  7. Click "OK" to save the changes
  8. Clean-up and re-run the test recovery to verify the failure no longer occurs