[VMC] HCX Plugin Fails to Load in vCenter for SDDC of version 1.26
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[VMC] HCX Plugin Fails to Load in vCenter for SDDC of version 1.26

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Article ID: 439846

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Updated On:

Products

VMware Cloud on AWS VMware HCX

Issue/Introduction

  • After deploying a new VMware Cloud on  AWS SDDC of version 1.26 or upgrading an existing SDDC to version 1.26, HCX Plug-in will fail to load from vCenter.
  • The HCX icon may be missing from the vCenter shortcut menu.
  • Selecting the HCX plugin results in a blank screen or throw the below error message:
    • Plugin failed to load
  • Other vCenter functionalities remain operational, but the integrated HCX management interface is inaccessible.

Environment

VMware Cloud on AWS

Cause

This issue is caused by a known compatibility conflict between HCX and the vCenter 8.0.3 included in the SDDC 1.26 release. The plugin registration fails to initialize correctly within this specific vCenter build, preventing the Add-on UI from rendering in the vSphere Client.

Resolution

  • Broadcom Engineering team is aware of this issue and are working on a fix. 
  • Customers are encouraged to monitor the VMware Cloud on AWS Release Notes for the announcement of this patch (VMware Cloud on AWS Release Notes)
  • Workaround: Customers should access the standalone HCX Manager UI for performing HCX related operations.
  • Steps to access the standalone HCX Manager UI:
    1. Log in to VMware Cloud Console (https://vmc.broadcom.com/home).
    2. Navigate to the Inventory tab and select your SDDC.
    3. Click on the Integrated Services tab.
    4. On the VMware HCX card, click Open HCX (or select the HCX Manager IP/FQDN).
    5. Log in using your vCenter credentials ([email protected]).
  • Note: All migration workflows, Network Extension configurations, and site pairings remain fully functional via the standalone HCX Manager interface.

Additional Information