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[VMC on AWS] Unable to login to HCX Cloud manager UI using AD account
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Article ID: 331527
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Updated On:
Products
VMware HCX
VMware Cloud on AWS
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Issue/Introduction
To understand a known limitation in HCX Cloud management in VMC on AWS SDDC deployment.
Symptoms:
AD users will be unable to log in to HCX Cloud manager UI
The error: "Invalid username or password, or too many active sessions" is seen when a login attempt is made.
Can successfully login to Cloud HCX management UI via the local account:
[email protected]
Cause
For customers leveraging HCX within a VMC on AWS SDDC, VMware only supports
usage of the
[email protected]
account.
Resolution
There is no resolution to this as it's as per product design. Kindly refer to the workaround section.
Workaround:
For On-Prem to Cloud (VMC on AWS) setup:-
Can configure HCX Role mapping in the HCX Connector (on-prem) side so that AD users can login and access HCX Connector manager UI. Reference document:
HCX Manager User Account and Role Requirements (vmware.com)
Can login to HCX Cloud manager UI using
[email protected]
instead.
For Cloud to Cloud setup:-
[VMC on AWS] AD unsupported for HCX Cloud to Cloud setup (90433) (vmware.com)
Additional Information
HCX Manager User Account and Role Requirements (vmware.com)
[VMC on AWS] AD unsupported for HCX Cloud to Cloud setup (90433) (vmware.com)
Impact/Risks:
Customers will be unable to login to the Cloud HCX Manager FQDN using an AD User.
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