Error: "VCF Operations Fleet Management is Not Ready" when navigating to VCF Management in VCF Operations 9.x
search cancel

Error: "VCF Operations Fleet Management is Not Ready" when navigating to VCF Management in VCF Operations 9.x

book

Article ID: 439054

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • VMware Cloud Foundation (VCF) Operations Fleet Management state displays as "VCF Operations Fleet Management is Not Ready". Attempts to disconnect or reconnect the node via the user interface (UI) fail with the following error message:

    Error connection Fleet Management node, try again

  • When investigating the logs on the Fleet Management and VCF Operations cluster, a No route to host (Host unreachable) error is observed when the system attempts to reach the VMware Cloud Foundation Automation (VCFA) instance VIP.

    2026-04-17T10:19:05.620Z ERROR vrlcm[1239] [pool-3-thread-38] [c.v.v.l.v.p.t.VcfaDeleteCapabilitiesTask]  -- Error while deleting capabilities from VCFA
    com.vmware.vrealize.lcm.vcfa.common.exception.UnableToGetVcfaTokenException: Could not get VCF Automation token for host: example.com username: admin@System. No route to host (Host unreachable)
    Caused by: java.net.NoRouteToHostException: No route to host (Host unreachable)

Environment

VCF Operations 9.0.x 

Cause

The VCF Operations environment cannot be removed or reconnected because the Fleet Management appliance is blocked by a routing failure to the VCFA instance VIP. This network inaccessibility prevents the completion of API requests, causing deletion and reconnection tasks to hang or fail.

Resolution

NOTE: There is a risk of deleting the Operations VMs and data if the deleteFromVcenter value is not set to false

To resolve the connection error and successfully re-add the Fleet Management node, manually clear the stale environment (VCF Automation in this case) and then remove the VCF Operations from API.

  1. Remove the inaccessible environment (VCF Automation in this case) from the UI and then VCF Operations using the API:

    • Navigate to Fleet Management > Lifecycle > Components > Automation > Delete
    • To remove VCF Operations, first use the steps in the following KB to access and authorize with the Fleet Management API.

    • In the Fleet Management API, in the Environment Controller section, select the Delete Environment option for the VCF Operations instance.
      NOTE: Ensure the deleteFromVcenter value is set to false.

    • Submit the request.

  2. Re-add the Fleet Management Appliance:

    • Once the API call returns a success status, log in to the VCF Operations Admin UI.

    • Follow the standard procedure to add the Fleet Management appliance.