Stale "IPAM IP Pool Usage Very High" alarm persists for deleted IP Pools in NSX Manager.
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Stale "IPAM IP Pool Usage Very High" alarm persists for deleted IP Pools in NSX Manager.

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Article ID: 437820

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Updated On:

Products

VMware NSX

Issue/Introduction

In NSX Manager, the "IPAM IP Pool Usage Very High" alarm may persist or repeatedly reappear in the Alarms dashboard even after the associated IP pool has been deleted and even if the allocated IPs are lesser than 90% of the total IPs which makes it a false alarm. Manual attempts to resolve the alarm via the NSX Manager UI are unsuccessful, as the alarm re-appears.

Environment

VMware NSX

Cause

The EventSource service maintains an entry for every alarm and relies on the source (in this case, IPAM) to send status updates, such as RESOLVED or OPEN. There is an issue while sending the information from IPAM to EventSource. Consequently, the EventSource retains the alarm as OPEN in its own data and continuously re-raises it during synchronization because it has no record of the alarm being finalized.

Resolution

This issue is resolved in VMware NSX 4.2.3 and VMware NSX 9.0.

Workaround:

  • Acknowledge the alarm on NSX Manager by accessing NSX Manager->Alarms-> Select the alarm and click on Acknowledge.

Or

  • Do a proton service restart on every manager node by: etc/init.d/proton restart. (Ensure that the proton service is up by running /etc/init.d/proton status post restart of the service before running the same on the next manager node)

Additional Information

VMware NSX Alarms UI displays "IP Pool Usage very high"