Clients Not Receiving Patch Update Policies Despite Successful Windows Assessment Scans
search cancel

Clients Not Receiving Patch Update Policies Despite Successful Windows Assessment Scans

book

Article ID: 437198

calendar_today

Updated On:

Products

Client Management Suite

Issue/Introduction

Clients are able to run Windows assessment scans and appear correctly in compliance reports. However, policy distribution is not functioning as expected, and clients are not receiving any patch update policies. 

We have observed multiple licensing errors, all of which occur immediately after the following message in the logs:

Failed to process licensing event batch...Every element in licenseInstances collection must be of type Base, Legacy, Trial.

pcAnywhereAgentBased :: Creating pcAnywhere Licensing Policy object

Environment

ITMS 8.7.3 

Cause

Known Issue. It was discovered that it was a missing record in the LicenseInUse table, preventing the client from receiving the software update policy.

The issue appears to be that the SMP core is unable to handle failed product licensing, which disrupts the entire licensing engine.

Resolution

This issue has been addressed in our next ITMS 8.8.2 release. 

A pointfix is available for the following release versions:

ITMS 8.7.3 Pointfixes

See KB 382575