Fails to activate Log Collection for Management domain vCenter in VCF Operations.
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Fails to activate Log Collection for Management domain vCenter in VCF Operations.

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Article ID: 436857

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

In a VMware Cloud Foundation (VCF) environment, users are unable to activate log collection for the Management Domain vCenter Server within VMware Aria Operations (formerly vRealize Operations).

Symptoms encountered include:

  • Log collection activation functions correctly and appears as expected in VCF Operations for Logs for the workload domain vCenters however, Log activation only fails for the Management Domain vCenter.
  • The vCenter integration is missing in VCF Operations for Logs under the Integration > vSphere option. Adding it manually in VCF Operations for Logs under Integration > vSphere resolves the issue
  • Connection validation for the Management Domain vCenter succeeds in VCF Operations.
  • Switching Management domain vCenter integration to use vCenter local SSO user fails to activate Log collection.

Environment

VCF Operations 9.x
VCF Operations for Logs 9.x

Cause

The log collection configuration row for the Management Domain vCenter is incomplete in the VCF operations internal database for Logs, and the associated credentials are missing, preventing the successful application of the log collection configuration.

Resolution

To resolve this issue, the incomplete database entry must be cleared so the configuration can be regenerated.
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