プロバイダーポータルの外部ネットワークにおいて、重複するIPアドレスが存在すると IP アドレスの使用状況が正しく表示されない
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プロバイダーポータルの外部ネットワークにおいて、重複するIPアドレスが存在すると IP アドレスの使用状況が正しく表示されない

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Article ID: 436036

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VMware Cloud Director

Issue/Introduction

免責事項:これは英文の記事「Incorrect IP Usage Information Displayed for Overlapping IP Addresses in Provider Portal External Networks」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

VMware Cloud Director (VCD) のプロバイダーポータルの [クラウドリソース] > [外部ネットワーク] > [対象のネットワーク] > [IP アドレス使用量] ([Resources] > [External Networks] > [Target Network] > [IP Usage])にて、以下の表示の問題が発生します。

  1. 重複した IP アドレス使用状況の表示
    同じIPアドレスが複数の異なる仮想マシン (VM) に割り当てられている場合、VM列とvApp列にそれぞれの固有の名前が表示されません。代わりに、特定のVMまたはvAppの名前が、そのIPアドレスを共有しているすべての行で誤って重複して表示されます。

  2. ソートした際に重複したエントリが増える
    上記の問題が発生している状態で、[IPアドレス] 列のヘッダーをクリックしてリストを並べ替えると、表示されている重複エントリの数がさらに増えます。(注: この事象は、重複したIPアドレスに加え、一覧に他のIPアドレスも含まれている場合に発生します)

Environment

VMware Cloud Director 10.6.x

Cause

これは VCD プロバイダーポータルの UI 表示実装の不具合に依る事象です。バックエンドのデータは正確ですが、重複するIPアドレスを処理する際、UI 側が固有のVM名やvApp名を正しくマッピングできていないことで発生しています。

Resolution

これは VCD の UI の既知の不具合です。

Broadcomのエンジニアリングチームは現在、将来のリリースでこの問題に対処するための修正プログラムを開発中です。

修正が適用されるまでの回避策として、ネットワークタイプが "直接" となっている同一ネットワーク内で重複する IP アドレスを登録している場合は、プロバイダーポータルではなく テナントポータルから IP アドレスの使用状況を確認してください。