Unexpected Max Virtual Service value in Service Engine Group in Active/Active mode
search cancel

Unexpected Max Virtual Service value in Service Engine Group in Active/Active mode

book

Article ID: 435952

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Tenant with LBaaS configured is not able to create new Virtual Services (VS).
  • The limit on the number of VSs was reached in NSX-ALB but not shown as reached in Cloud Director (VCD).
  • The Service Engine Group(SEG) is configured in High Availability Mode: Active/Active.
  • On the VCD Provider UI page Resources > Infrastructure Resources > NSX-ALB > Service Engine Groups the incorrect Max Virtual Service is displayed.
  • On VCD cell in the log /opt/vmware/vcloud-director/logs/vcloud-container-debug.log the VS calculation is seen as follows:

    DEBUG    | task-service-activity-pool-### | NsxAlbLoadBalancerServiceEngineGroup | Service Engine Group ########-####-####-####-######## has max virtual services 100 (10 SEs x 10 virtual services per SE) | requestId=########-####-####-####-########,request=POST https://<vcd>/cloudapi/1.0.0/loadBalancer/serviceEngineGroups/urn:vcloud:serviceEngineGroup:########-####-####-####-########

Environment

  • VMware Cloud Director 10.6.1.x
  • VMware Avi Load Balancer 30.2.x

Cause

This issue occurs as Cloud Director calculates the Max Virtual Service using the formula (Number of Service Engine × Virtual Services per Service Engine) for a SEG in Active/Active mode. Cloud Director does not account for the Scale per Virtual Service (min) or Scale per Virtual Service (max) values which can be configured directly on the SEG in NSX-ALB. 

Resolution

This is a known issue which will be addressed in a future release. 

Subscribe to this knowledge article to get updates on this issue.