NSX Manager UI displays error "Failed to fetch System details" due to search index re-creation.
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NSX Manager UI displays error "Failed to fetch System details" due to search index re-creation.

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Article ID: 435712

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Updated On:

Products

VMware NSX

Issue/Introduction

When attempting to access the NSX Manager UI, the system displays the following error.

Error: Failed to fetch System details. Please contact the administrator. Error: 400 : "{ "httpStatus" : "BAD_REQUEST", "error_code" : 60508, "module_name" : "nsx-search", "error_message" : "Re-creating indexes, this may take some time."}" (Error code: 513002).

Environment

 

VMware NSX

 

Cause

The error occurs when the nsx-search module is stuck or delayed while re-creating indexes. This state prevents the Manager from returning system details to the UI. 

Resolution

Workaround:

A resync may be forced by running the following command on all three NSX Managers appliances: start search resync all
Note: The process may take several hours to complete.

Additional Information

The final resolution and validation of this issue require an inspection of the NSX Manager Corfu database tables. If the workaround does not restore service after several hours, please contact Broadcom Support for further assistance.