Unable to access or view the web console for any Virtual Machines through the vSphere Client UI.
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Unable to access or view the web console for any Virtual Machines through the vSphere Client UI.

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Article ID: 435688

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Unable to access or view the web console for any Virtual Machines through the vSphere Client UI.

  • The vpxd-svcs service is found in a stopped state and fails to start, including when attempting a manual restart.

  • From /var/log/vmware/vpxd-svcs/pre-start-vpxd-svcs.log, we see entries related to "Invalid certificate"

    YYYY-MM-DDThh:mm:ssZ ERROR:tagging_grpc_registration:Failed to reregister Tagging service grpc endpoints with Lookup Service
    YYYY-MM-DDThh:mm:ssZ ERROR:tagging_grpc_registration:(vmodl.fault.InvalidArgument) {
       dynamicType = <unset>,
       dynamicProperty = (vmodl.DynamicProperty) [],
       msg = '',
       faultCause = <unset>,
       faultMessage = (vmodl.LocalizableMessage) [],
       invalidProperty = 'Invalid certificate'
    }

Environment

VMware vCenter Server 7.0.x

VMware vCenter Server 8.0.x

Cause

The issue occurs because one or more certificates in vCenter are expired, invalid, or missing CA.

 

Resolution

NOTE:- Ensure backups or offline snapshots exist before making certificate changes. See: VMware vCenter in Enhanced Linked Mode – backup considerations


Steps to follow: 

   1) Renew the vCenter certificates using the VMware Certificate Management Tool .

   2) Then restart all the services to bring up the services.