Refresh vCenter task from VCF Automation fails with error "No Supervisor found with address"
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Refresh vCenter task from VCF Automation fails with error "No Supervisor found with address"

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Article ID: 435598

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When attempting to refresh vCenter from VCFA 9.0.1 Provider portal > General Settings > Connections > vCenter Servers > specific vCenter > vertical ellipses > Refresh > Fails with error : No Supervisor found with address: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx
  • When attempting to refresh vCenter from VCFA 9.0.1 Provider portal > General Settings > Connections > vCenter Servers > specific vCenter > vertical ellipses > Reconnect / Refresh Policies > completes successfully
  • Attempting to view supervisors on VCFA provider portal > Infrastructure > Supervisors > show stale supervisors, which no longer exist. 
  • Attempting to view supervisors mapped to Regions : VCFA provider portal > Infrastructure > Regions > Supervisors : show stale supervisors mapping. 

Environment

  • VCF Automation 9.x

Cause

  • The supervisor cluster was modified / removed outside of VCF Automation directly on the control plane prior addressing dependencies on VCFA and the changes were not synced with VCF Automation.  

Resolution

  • Ideally, when intending to remove / modify a supervisor cluster, you must validate the dependencies on the region on VCFA. Refer: Edit a Region
  • Workaround:
    • If there are active deployments / associations to the concerned region and/or If deletion of the region isn't possible, however the associated supervisor(s) have been deleted, reach out to Broadcom Support for assistance, as we would need to identify and remove possible staleness. 
    • If there aren't any deployments / associations done from VCFA to the supervisor cluster, delete / recreate the associated region:
      • Delete the existing region
        (Note: you would have to clear any quotas or storage classes created on the region prior)
        • Log in to the VCF Automation Provider Management Portal.
        • From the left navigation panel, under Infrastructure, select Regions.
        • Select the region.
        • Select Delete, and confirm.
      • (Optional) Create the region, if required, as per: Create a Region in Your VCF Automation
      • Run the Refresh action on vCenter Connection from VCFA Provider portal > Connection > vCenters > vertical ellipses > Refresh.