HCX Bulk Migration Fails with error Initial Sync Failed Error while executing namedquery
search cancel

HCX Bulk Migration Fails with error Initial Sync Failed Error while executing namedquery

book

Article ID: 435289

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Migration fails with error Initial Sync Failed Error while executing namedquery : getTransferDefinitionsWithTransferId namespace :transfer match : {transferGroupId=########}

Environment

VMware HCX

Cause

VMware HCX migration failures involving the error "Initial Sync Failed" combined with "Error while executing namedquery" are typically related to environment or communication issues between HCX components and vCenter or a failure during database interactions within the HCX Manager, often specifically involving PostgreSQL functions related to replication transfers

Resolution

Re-register the Source vCenter.

  • Log in to the Source HCX Appliance Management Interface at https://<Source-HCX-Manager-IP>:9443.
  • Navigate to the vCenter Server registration section under 'Dashboard'.
  • Edit the vCenter configuration, re-enter the administrator credentials and save.
  • Accept the vCenter certificate prompt to re-establish the connection.
  • Restart web and app services. Refer How to restart HCX Manager services or use the below commands.
    • systemctl restart app-engine
    • systemctl restart web-engine

Now retry the migration and if it fails again, follow below steps; 

Restart the HBR Service on the IX Appliance.

    • SSH to IX appliance via the HCX Manager appliance.
    • Execute the following command to restart the Host-Based Replication service:
      • systemctl restart hbrsrv
    • Verify the service is running correctly:
      • systemctl status hbrsrv

Retry the Bulk Migration from the HCX UI. The initial sync should now proceed successfully.

Additional Information

HCX-MIG-BULK