ESXi host management network unreachable after physical network adapter replacement or new host configuration
search cancel

ESXi host management network unreachable after physical network adapter replacement or new host configuration

book

Article ID: 434918

calendar_today

Updated On:

Products

VMware vSphere ESXi 8.0

Issue/Introduction

An ESXi host in a cluster loses management connectivity following a physical hardware change or a new deployed ESXi host is unable to connect to management network on a specific vmnic adaptor.
The host is unable to reach its default gateway or any other IP address on the management segment despite correct VLAN and IP configuration in the DCUI.

Environment

VMware vSphere ESXi

Cause

VLAN mismatch resulting from incorrect physical cabling.

Resolution

  • Identify the correct physical cabling and switch port mapping for all hosts in the cluster to ensure uniformity.

    To validate the physical-to-virtual mapping for the ESXi host Access the ESXi host using DCUI
  1. Enter the command esxcfg-info -n 
  2. Search for the CDP Summary/LLDP Summary section in the output for the desired vmnic.

  • If CDP/LLDP information is not visible, note down the mac address of vmk0 using the command: esxcfg-vmknic -l and trace from the physical switchport side if it is being learnt at the intended switchport.
  • Verify that the physical switch ports are configured with the correct Management VLAN.

  • Swap physical cables at the hardware end to match the existing ESXi vmnic configuration if ports have been shifted. If the cabling is correct then verify that required VLAN is configured on the physical port.

Additional Information

For further troubleshooting, use pktcap-uw to capture traffic on both the VMkernel adapter and the physical uplinks. Follow KB Packet capture on ESXi using the pktcap-uw tool.