vCenter appliance back up fails due to vmware-perfcharts service in stopped state
search cancel

vCenter appliance back up fails due to vmware-perfcharts service in stopped state

book

Article ID: 434592

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to start the vmware-perfcharts service, the following error is encountered:

    Error executing start on service perfcharts. Details {
        "detail": [
            {
                "id": "install.ciscommon.service.failstart",
                "translatable": "An error occurred while starting service '%(0)s'",
                "args": [
                    "perfcharts"
                ],
                "localized": "An error occurred while starting service 'perfcharts'"
            }
        ],
        "componentKey": null,
        "problemId": null,
        "resolution": null
    }
    Service-control failed. Error: {
        "detail": [
            {
                "id": "install.ciscommon.service.failstart",
                "translatable": "An error occurred while starting service '%(0)s'",
                "args": [
                    "perfcharts"
                ],
                "localized": "An error occurred while starting service 'perfcharts'"
            }
        ],
        "componentKey": null,
        "problemId": null,
        "resolution": null

  • /var/log/vmware/vmon/vmon.log:

    YYYY-MM-DDTHH:MM:Sec.099Z Er(02) host-2564 <perfcharts> [Process: 996884] Failed to redirect std-stream. Error: Permission denied
    YYYY-MM-DDTHH:MM:Sec.099Z Wa(03) host-2564 <perfcharts> Service exited. Exit code 254
    YYYY-MM-DDTHH:MM:Sec.100Z Wa(03) host-2564 [ReadSvcSubStartupData] No startup information from perfcharts.

Environment

  • VMware vCenter server Appliance 8.0.3 

Cause

The issue was caused by incorrect file permissions and ownership on the directory /var/log/vmware/perfcharts/. As a result, the VMware perfcharts service was unable to access or write to the log directory.

Resolution

  • 1) Login to the vCenter server appliance using the root credentials.

    2) Set the appropriate ownership for the vmware-updatemgr directory and its contents using the following commands:

    chown -R perfcharts:users /var/log/vmware/perfcharts/

    3) Restart the Update Manager service

    vmon-cli --start updatemgrservice-control --start vmware-perfcharts

     4) If the issue persists after applying the above steps, please contact Broadcom Technical Support for further assistance.

Additional Information

  • The general syntax is: chown -R [user]:[group] /path/to/folder