Log Collection status shows as "Failed" after upgrading to 9.0.2
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Log Collection status shows as "Failed" after upgrading to 9.0.2

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Article ID: 433361

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Updated On:

Products

VCF Operations

Issue/Introduction

Following the upgrade of VCF Operations, VCF Operations for Logs, and VCF Operations for Networks from version 9.0.1 to 9.0.2, the Log Collection status for all components displays as "Failed" under the Infrastructure Operations > Configurations > Log Collection page.

Clicking directly on the "Failed" status for the VCF Operations component reveals the specific error message: "Failed to propagate configuration to CP"

Despite the UI reporting this failure, logs continue to be successfully ingested by the VCF Operations for Logs appliance during this time. You can confirm this by checking the Infrastructure Operations > Analyze page and choosing the proper filters and timeline, which will show no significant drop in the actual log count since the upgrade.

Environment

VCF Operations 9.0.x
VCF Operations for Logs 9.0.x

Cause

The "Failed" status may be caused by a failure to propagate the log collection configuration to a specific Cloud Proxy that is not part of the Management Domain.

Because this propagation fails during the automated post-upgrade inventory sync (which runs silently in the background), the overall Log Collection status for the components incorrectly reflects a "Failed" state in the UI.

There is no active adapter stoppage or functional failure between the components. This is a UI state mismatch.

Resolution

Before proceeding, confirm that logs are successfully ingesting by navigating to the Infrastructure Operations > Analyze page and applying the proper filters and timeline to view the log count since the upgrade.

Once log ingestion is confirmed and the issue is identified as a UI state mismatch, you can resolve the "Failed" status immediately by manually initiating an Inventory Sync for the affected components, skipping the unmanaged Cloud Proxy (if applies) or resolving any other sync failure:

  1. Manually initiate an Inventory Sync for VCF Operations, VCF Operations for Networks, and VCF Operations for Logs.
  2. Navigate to the task details for any failed Inventory Sync.
  3. Select the option to skip the problematic Cloud Proxy that is not part of the Management Domain or resolve any other sync failure(s).
  4. Allow the manual inventory sync to complete successfully. This forces the system to immediately refresh the integration states and return the Log Collection UI to an accurate "Active" status.

Alternatively, you can allow time for the system to process background tasks. The UI state mismatch will self-correct after a few hours / days as automated background processes eventually resolve the temporary disconnect.

Additional Information

vCenter Log Collection status shows Failed in the VCF Operations UI