NSX Manager Search Service Degraded due to Indexing Exception
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NSX Manager Search Service Degraded due to Indexing Exception

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Article ID: 433070

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Updated On:

Products

VMware NSX

Issue/Introduction

The NSX Manager Search service status displays as Degraded in the UI, and users are unable to perform inventory searches. A rolling reboot of the NSX Manager cluster does not resolve the issue.

The var/log/manager/ logs indicate an indexing failure associated with a specific group 

ERROR [nsx@6848 comp="nsx-manager" errorCode="MP60511" level="ERROR" subcomp="manager"] [Indexing: DataProvider] Could not convert UFO object to Dto UfoObject{operationType=CREATE, descriptor=IndexingTypeDescriptor{tableName='Group', streamTag=POLICY}, identifier=string_id: "/global-infra/domains/<DOMAIN_NAME>/groups/<GROUP_ID>=="...}
java.lang.reflect.InvocationTargetException: null
        at jdk.internal.reflect.GeneratedMethodAccessor.invoke(Unknown Source) ~[?:?]
...
Caused by: com.vmware.nsx.management.search.common.exceptions.SearchException: INDEXING_EXCEPTION
        at com.vmware.nsx.management.search.dataprovider.PolicyGroupDataProvider.getIsGeoIpGroupToIndex...
...
ERROR [nsx@6848 comp="nsx-manager" errorCode="MP60503" level="ERROR" subcomp="manager"] [Indexing: Processing] An error occurred while trying to process UfoObject...
com.vmware.nsx.management.search.common.exceptions.SearchException: CANNOT_INVOKE_PROVIDER

Environment

VMware NSX

Cause

During site or configuration onboarding in a federated environment, a parent group is onboarded to the Global Manager (GM) containing a PathExpression that references a nested child group. If the child group is a Transport Node (TN) member group, it is correctly excluded from onboarding. However, the parent group bypasses the filter, resulting in a dangling path reference on the GM. When the system attempts to resolve this missing group path, it throws an ObjectNotFoundException, which causes an INDEXING_EXCEPTION that crashes the indexing process and degrades the Search service.

Resolution

To resolve the issue following the KB NSX Manager Search service status is not UP

If the above steps do not resolve the issue, raise a support ticket with Broadcom support selecting NSX as the product. 

Handling Log Bundles for offline review with Broadcom support.