Ghosted Device Cards on Windows VMs After HCX vMotion/RAV/Bulk/Cold Migration
search cancel

Ghosted Device Cards on Windows VMs After HCX vMotion/RAV/Bulk/Cold Migration

book

Article ID: 432699

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • Windows virtual machines migrated via HCX Replication Assisted vMotion (RAV)/vMotion/Bulk/Cold exhibit "ghosted" or duplicate hardware devices (specifically NICs/Network Cards) within the Guest OS after a reboot or hardware scan.
  • This occurs consistently across migrated Windows workloads.

Symptoms:

  • Windows Device Manager shows ghosted/hidden devices and PCI numbers change.

  • Network configuration is lost or reassigned to a new "ghost" adapter.

  • Issue is specific to Windows VMs with EFI firmware and a source Hardware Version > 20.

  • The source VM started out on a Hardware Version < 20.

Environment

 

  • Product: VMware Cloud Foundation (VCF), VMware HCX

  • Component: IX Appliance, Mobility Agent

  • Guest OS: Microsoft Windows (All versions using EFI)

  • VM Hardware Version: 20 and above (Source side)

 

Cause

  • The issue is caused by a change in the Motherboard Layout during the migration process.
  • When HCX (or vCenter) executes the CreateVM API to construct the VM specification on the destination, the motherboard_layout property from the source "running config" is not explicitly carried over.
  • For EFI-based VMs, the destination vCenter defaults the new VM to the ACPI (Advanced Configuration and Power Interface) layout.
  • Windows perceives this as a hardware change, leading to the re-enumeration of devices and the "ghosting" of previous hardware entries (PCI Tree changes).

Resolution

This issue is resolved in VMware HCX 4.11.5, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

 

Additional Information

Note: VMware HCX 4.11.5 is not yet qualified for the VMC on AWS environment. Please subscribe to this KB article to receive updates.