'Cannot connect to storage' alarms following improper LUN or datastore decommissioning
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'Cannot connect to storage' alarms following improper LUN or datastore decommissioning

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Article ID: 432605

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Under Monitor > Triggered Alarms, the below warning is listed:

 

Environment

VMware vSphere ESXi 8.x

VMware vSphere ESXi 9.x

Cause

This is caused by unmapping a LUN from the storage array before performing a clean detach operation on the ESXi host. Without being properly detached, ESXi treats the missing LUN as an unexpected outage and continuously attempts to reconnect.

These repeated connection failures are what trigger the "Cannot connect to storage" alarms across the ESXi's where the device was still attached.

  • In vobd.log, lost connectivity or degraded storage path messages are logged:

YYYY-MM-DDTHH:MM:SS.###Z : [scsiCorrelator] 18318798846865us: [vob.scsi.scsipath.pathstate.dead] scsiPath vmhba1:C0:T1:L244 changed state from on
YYYY-MM-DDTHH:MM:SS.###Z : [scsiCorrelator] 18318899691848us: [esx.problem.storage.connectivity.lost] Lost connectivity to storage device naa.##############. Path vmhba1:C0:T1:L244 is down. Affected datastores: Unknown.

  • Running the command esxcli storage core device detached list | grep naa.########## shows this LUN under the detached list output:

Device UID                            State
------------------------------------    -----
naa.###########                 off



Resolution

To properly decommission storage and prevent these alarms, follow:

Evacuate all VMs and data > Unmount and delete the datastore > Detach the device from the ESXi host > Unpresent the LUN from the external storage array.

For further details see: Detach a LUN device from ESXi hosts