特定組織においてタスク実行時 "The maximum number of simultaneous operations for organization has been reached" エラーが発生する
search cancel

特定組織においてタスク実行時 "The maximum number of simultaneous operations for organization has been reached" エラーが発生する

book

Article ID: 432016

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

免責事項:これは英文記事「Error: "The maximum number of simultaneous operations for organization has been reached" when performing tasks on a specific Organization」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


  • ある組織内のユーザーが実行したタスクは、全て以下エラーにより失敗する。

    [ ########-###-####-########ef6d ] The maximum number of simultaneous operations for organization "{Organization name}" has been reached.
     - java.lang.IllegalArgumentException: com.vmware.vcloud.activity.persistence.ActivityPersistenceException: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: Activity queue is full.

  • VMware Cloud Director (VCD) において、組織およびユーザーのタスク数に上限が設定されている。

Environment

VMware Cloud Director 10.6.x

Cause

この問題は、組織に何らかの上限が設定されており、ユーザーまたは組織のタスク数がユーザー毎のタスク数、あるいは組織毎のタスク数の上限に達した場合に発生します。

上記状況においてタスクがキャンセルされるか失敗すると、関連するレコードがデータベース上に残存する場合があります。

Resolution

VCD データベース上の activity テーブルをクリアするため、VCD セルを再起動してください。

さらなる情報については Perform an Orderly Shutdown and Startup of Your VMware Cloud Director Appliance Cluster 上のドキュメントをご参照ください。

Additional Information

組織の制限を確認・変更するには Configure Policies for a VMware Cloud Director Organization 上のドキュメントをご参照ください。

関連する設定は以下の通りです。

Number of resource-intensive operations per user
Number of resource-intensive operations to be queued per user
Number of resource-intensive operations per organization
Number of resource-intensive operations to be queued per organization