Error: "The maximum number of simultaneous operations for organization has been reached" when performing tasks on a specific Organization
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Error: "The maximum number of simultaneous operations for organization has been reached" when performing tasks on a specific Organization

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Article ID: 431590

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • All the task initiated from a user for one organization fails with the error:

    [ ########-###-####-########ef6d ] The maximum number of simultaneous operations for organization "{Organization name}" has been reached.
     - java.lang.IllegalArgumentException: com.vmware.vcloud.activity.persistence.ActivityPersistenceException: java.util.concurrent.ExecutionException: java.lang.IllegalStateException: Activity queue is full.

  • Limits for the Organization and user tasks have been configured on VMware Cloud Director (VCD).

Environment

VMware Cloud Director 10.6.x

Cause

This issue occurs if there are any limits set on the Organization and a user or the organization reach the user/tasks or organization/tasks maximum limits.

When tasks are cancelled or failed due to above scenario, the associated records often persist within the database.

Resolution

Rebooting the VCD cells in order to clean the activity tables on VCD database. 

For additional l information visit the documentation on Perform an Orderly Shutdown and Startup of Your VMware Cloud Director Appliance Cluster

Additional Information

To review and modify the Organization Limits visit the documentation Configure Policies for a VMware Cloud Director Organization

Relvevent settings are:

Number of resource-intensive operations per user
Number of resource-intensive operations to be queued per user
Number of resource-intensive operations per organization
Number of resource-intensive operations to be queued per organization

特定組織においてタスク実行時 "The maximum number of simultaneous operations for organization has been reached" エラーが発生する