"VSAN Build Recommendation Engine Health": "Unexpected VMware Update Manager (VUM) baseline creation failure. Please check vSAN and VUM logs for details."
search cancel

"VSAN Build Recommendation Engine Health": "Unexpected VMware Update Manager (VUM) baseline creation failure. Please check vSAN and VUM logs for details."

book

Article ID: 431164

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • vSAN Cluster reports following alert in vSAN Skyline Health in vSphere Client:

    "VSAN Build Recommendation Engine Health":

    Issue information:
    "Unexpected VMware Update Manager (VUM) baseline creation failure. Please check vSAN and VUM logs for details."


Environment

  • VMware vSAN 8.x

Cause

  • Issue occurs as Vmware Life Cycle Manager (VLCM) no longer uses old URLS (starting with hostupdate.vmware.com..) which were earlier used by now-deprecated Vmware Update Manager (VUM).

  • This results in the URLs not reachable by vCenter server.

(/var/log/vmware//vmware-updatemgr/vum-server/vmware-vum-server.log)

2026-02-26T09:59:07.296+11:00 verbose vmware-vum-server [09116] [Originator@6876 sub=httpDownload] [httpDownloadPosix 188] * Could not resolve host: hostupdate.vmware.com

2026-02-26T09:59:07.297+11:00 verbose vmware-vum-server [09116] [Originator@6876 sub=httpDownload] [httpDownloadPosix 188] * shutting down connection #17

2026-02-26T09:59:07.297+11:00 error vmware-vum-server[09116] [Originator@6876 sub=httpDownload] [httpDownloadPosix 767] curl_easy_perform() failed: CURL Error: Could not resolve host: hostupdate.vmware.com

Resolution

  1. Follow steps provided in following KB to generate Download Token from Broadcom support portal and then change URLs in LifeCycle Manager Settings.

    "vSAN Build Recommendation Engine Health" - "VMware ISO download site is down"

  2. If 'Generate Download Token' option stated in KB in step-1 is missing on Broadcom support portal, follow KB below to fix that issue with missing option and then follow above stated KB again.

"Generate Download Token" missing in the Quick links on Broadcom Support Portal