Locked accounts on VCF Operations and report disconnected in Fleet Management password menu.
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Locked accounts on VCF Operations and report disconnected in Fleet Management password menu.

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Article ID: 430936

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Root accounts for VCF Operations & Fleet Management display as disconnected or locked within the 'Password' menu in the VCF Operations UI.
  • Fleet Management shows a "VCF Operations Fleet Management is not Ready" state.

  • Attempts to remediate the locked passwords directly through the UI fail with the error;

    • Remediate for applaince <Appliance_FQDN> has failed. 
  • After successfully updating the passwords via the command line, the UI may continue to incorrectly display the accounts as locked despite a "Success" message.

Environment

  • VCF Operations 9.0.x
  • VCF Fleet Management 9.0.x

Cause

Lockouts are caused by local password expiration policies enforcing a time-based expiration on the root accounts.

Resolution

  1. Follow the steps in the KBs below to reset the root account passwords for the Fleet Management and VCF Operations appliances. .
  2. Restart Fleet management services by running the command below;
    • restart vrlcm-server.service
  3. Reattempt the password remediation in the 'Password' tab of the 'Fleet Management' menu in the VCF Operations UI.
  4. If the password remediation is successful, but the accounts remain 'Disconnected', please reboot the Fleet Management appliance.

Additional Information

To Prevent future lockouts on VCF Operations and Fleet Management by setting the root password to never expire using the command:

  • chage -M -1 root