VCF Fleet Manager root account disconnected in VCF Operations
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VCF Fleet Manager root account disconnected in VCF Operations

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Article ID: 422906

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Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation VCF Operations

Issue/Introduction

When viewing Fleet Manager > Password > VCF Management within VMware Cloud Foundation (VCF) Operations Manager, the root account for the Fleet Manager appliance displays a status of Disconnected.

Environment

VMware Cloud Foundation 9.x

VMware vSphere Foundation 9.x

Cause

This issue occurs when the root password for the Fleet Manager appliance operating system has expired.

Resolution

To resolve this issue, reset the expired root password on the appliance and then remediate the password within the Operations Manager UI.

Steps to follow:

  1. Take a snapshot of the Fleet Manager appliance before proceeding. Ensure Quiesce guest file system and Snapshot the virtual machine's memory are unchecked.

  2. Reset the Appliance Root Password
    1. Open a web or remote console to the Fleet Manager Appliance.
    2. Log in using the root user and the current password.
    3. The system will prompt that the password has expired.
    4. Enter the current password again when prompted
    5. Enter a new password and confirm it.

      Note: Avoid using special characters like ( !, #, %, &, |, <, >, ;, ', or " )in the new password to prevent potential parsing issues.

  3. Remediate in VCF Operations Manager
    1. Log in to the VCF Operations Manager UI.
    2. Navigate to Fleet Manager > Password > VCF Management.
    3. Select the root account that is showing as Disconnected.
    4. Click Remediate.
    5. Enter the new password created in the previous section.

      If successful, a banner will appear: "Password remediation for appliance <FQDN> is successful. Changes may take some time to appear."

  4. If the remediation step fails, perform the following steps on the Fleet Manager Appliance via SSH:
    1. SSH to the Fleet Manager Appliance as root.
    2. Disable the cap_init service:
      systemctl disable cap_init
      systemctl daemon-reload
    3. Restart the Nginx service:
      systemctl restart nginx
    4. Restart the Lifecycle Manager service:
      systemctl restart vrlcm-server.service
    5. Wait a few minutes for services to initialize. Verify status with:
      systemctl status vrlcm-server.service
  5. Retry the Remediate action in the VCF Operations Manager UI.

Additional Information

Since the password validation check runs periodically, it may take anywhere from 1 to 24 hours for the password status to update to Active (green) after remediation.