Compute Manager is in "Registered with errors" state in NSX-T
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Compute Manager is in "Registered with errors" state in NSX-T

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Article ID: 430868

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Status of Compute Manager in VMware NSX-T is in "Registered with errors".
  • When you click on the status, you will message below:
    Failed to remove NSX ownership due to error Error in rest call. url= nsxapi/api//v1/managed-objects/lcm/nsx-ownership/########-####-####-####-#########a3d1?action=clear , method= PUT , response= { "module_name" : "common-services", "error_message" : "General error has occurred.", "details" : "java.lang.RuntimeException: java.net.ConnectException: Connection timed out (Connection timed out)", "error_code" : 100 } , error= 500 : "{<EOL> "module_name" : "common-services",<EOL> "error_message" : "General error has occurred.",<EOL> "details" : "java.lang.RuntimeException: java.net.ConnectException: Connection timed out (Connection timed out)",<EOL> "error_code" : 100<EOL>}<EOL>" .. Please resolve the error and try again.
  • In NSX Manager's /var/log/cm-inventory/cm-inventory.log, you will see logs like:
    cm-inventory/cm-inventory.log
    2026-02-23T09:41:48.567Z  INFO inventoryTasksScheduler1 CmPluginStateManager 4333 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="cm-inventory"] CM ########-####-####-####-#########a3d1 mapped to this node and current status is discovered_resource {
    ...
    connection_status: COMPUTE_MANAGER_CONNECTION_STATUS_UP
    registration_status: COMPUTE_MANAGER_REGISTRATION_STATUS_REGISTERED_WITH_ERRORS
    cm_plugin_status: CM_PLUGIN_STATUS_STARTED
    ...
    registration_error {
      error_message {
        value: "Failed to remove NSX ownership due to error Error in rest call. url= nsxapi/api//v1/managed-objects/lcm/nsx-ownership/########-####-####-####-#########a3d1?action=clear , method= PUT , response= {\n    \"module_name\" : \"common-services\",\n    \"error_message\" : \"General error has occurred.\",\n    \"details\" : \"java.lang.RuntimeException: java.net.ConnectException: Connection timed out (Connection timed out)\",\n    \"error_code\" : 100\n}\n , error= 500 : \"{<EOL>    \"module_name\" : \"common-services\",<EOL>    \"error_message\" : \"General error has occurred.\",<EOL>    \"details\" : \"java.lang.RuntimeException: java.net.ConnectException: Connection timed out (Connection timed out)\",<EOL>    \"error_code\" : 100<EOL>}<EOL>\" .. Please resolve the error and try again."
      }
      timestamp: 1771920064995
      error_code: 90325
    }
    reverse_proxy_http_port: 80
    oidc_end_point_entity_id {
      value: "###########"
    }
  • /var/log/cm-inventory/cm-inventory.log will also indicate connection exceptions:
    2026-02-23T22:22:29.196Z  WARN InventoryFetcher-########-####-####-####-#########a3d1 VcUtilsImpl 4333 SYSTEM [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="cm-inventory"] ConnectException occurred
  • Compute Manager will otherwise appear healthy:
    • Certificate is healthy (unbroken chain of trust, all certificates are valid, and the SHA256 thumbprint of the certificate is matching the certificate thumbprint in NSX):
      openssl s_client -connect <Compute_Manager>:443 -showcerts
    • NSX Manager does have connectivity to the Compute Manager on TCP ports 80 and 443:
      nc -zv <Compute_Manager> 443
      nc -zv <Compute_Manager> 80

Environment

VMware NSX-T Data Center earlier than 3.2.4.

Cause

In NSX-T Data Center versions earlier than 3.2.4, ip_blackhole feature is enabled on the kernel level. 
This feature is known to be causing unexpected TCP timeouts. 

Resolution

This issue is resolved in VMware NSX-T Data Center 3.2.4, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

Please note VMware NSX-T Data Center 3.2.x has reached the End of General Support on October 2, 2025. Broadcom recommend to upgrade to a fully supported version.

Please refer to the Product Lifecycle documentation (requires login to Broadcom Support portal).

 

Workaround:

If you are unable to upgrade to a version with a fix, please disable the ip_blackhole feature:

  1. SSH to NSX Manager node as root.
  2. Persist the change:
    echo 'echo 0 > /proc/sys/kernel/grsecurity/ip_blackhole' >> /opt/vmware/nsx-node-api/bin/set_params.sh
  3. Make a change in runtime:
    echo 0 > /proc/sys/kernel/grsecurity/ip_blackhole
  4. Confirm the change has taken the place (value in the output should read 0):
    cat /proc/sys/kernel/grsecurity/ip_blackhole
  5. Repeat the same steps on the remaining NSX Managers.

Notes:

  • Introduction of the workaround is non-disruptive.
  • Reboot of the Managers is not required for the workaround to take effect. 
  • The workaround needs to be re-applied if the Manager was restored from backup, or re-deployed.
  • Workaround needs to be re-introduced post upgrade to version below 3.2.4.