Admin UI hangs during manual upgrade to VCF Operations 9.0.2.0
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Admin UI hangs during manual upgrade to VCF Operations 9.0.2.0

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Article ID: 430632

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VCF Operations

Issue/Introduction

  • You attempt to perform a standalone / out-of-band upgrade of an Aria Operations cluster from version 8.18.3 to VCF Operations 9.0.2.0.

    Note that this method is outside the recommended process of upgrading from 8.18.x to 9.0.x using LCM and Fleet Management for a standard VCF 9.x brownfield deployment.

  • After you upload the upgrade PAK file (Operations-Upgrade-9.0.2.0.25137843.pak) in the Admin UI, the upgrade starts but the interface seems to hang or is not updating.
  • The Admin UI displays a stuck upgrade status where the Steps Completed on the primary node is on step '6 of 14 - Deployed new upgrade content' and the 2 data nodes are showing '1 of 14 - Not Distributed'. The Executing column is blank.
  • You attempt the steps from the KB Reset the upgrade status of Aria Operations (319676), but they fail to resolve the issue.
  • Clicking on 'Cancel Installation' or 'Finish Installation' does not work

Environment

Aria Operations 8.18.3 and above
VCF Operations 9.0.x

Cause

The upgrade stalls because the "Ignore the PAK File Signature Checking" checkbox is selected during the initial PAK file upload. VCF Operations 9.0.x does not support bypassing the signature check for this specific product upgrade PAK.

You observe the following errors on the primary node log located at /storage/log/vcops/log/casa/admin-ui.log:

2026-02-18T23:02:46,869+0000 INFO [ajp-nio-###.#.#.#-8011-exec-29] com.vmware.vcops.util.admin.HTTPSRequester:503 - Response : {"error_message_key":"pak_manager.pakfile.signature_checkbox_misused","error_arguments":["Operations-Upgrade-9.0.2.0.25137843.pak"],"error_message":""}
2026-02-18T23:02:46,871+0000 ERROR [ajp-nio-###.#.#.#-8011-exec-29] com.vmware.vcops.util.admin.solution.SolutionManagement:282 - CaSA response: 500
2026-02-18T23:02:46,871+0000 ERROR [ajp-nio-###.#.#.#-8011-exec-29] com.vmware.vcops.adminui.service.PakUploadService:137 - Error reported while trying to upload the solution (Operations-Upgrade-9.0.2.0.25137843.pak) : Ignore the signature checkbox shouldn't be used with product pak

Resolution

To resolve the stuck upgrade and apply version 9.0.2.0, perform the following steps:

  1. If needed, reset the root account password on the secondary nodes and clear the admin account lockout to restore access.

    Note: See KBs referenced in the Additional Information section below.

  2. Take the cluster offline from the Admin UI using the Take Offline button.

  3. Power off the cluster nodes once the cluster is successfully Offline, remove old snapshots, and take new offline snapshots - Snapshot Creation in VMware Aria Operations

  4. It is best practice to bring the cluster back online at this point and ensure functionality of the pre-upgrade state. If the cluster was not healthy prior to the upgrade or improper snapshots were taken causing a cluster online failure, the upgrade itself will not fix this.

  5. If the cluster online operation is successful and you can successfully login to the application and functionality is as expected, take the cluster offline from the admin UI 
  6. Keep the cluster offline at the start of the upgrade process.

  7. Select Install a Software Update.

  8. Upload the 9.0.x pak file (e.g. Operations-Upgrade-9.0.2.0.25137843.pak)
  9. Check the top checkbox to Install the PAK file even if already installed to overwrite any stuck state.

  10. Ensure the second checkbox for Ignore the PAK File Signature Checking is left unchecked.

Additional Information

Additionally, backend authentication failures might occur due to the admin account lockout and/or expired root passwords on secondary nodes. If the account password expire or get locked out, the upgrade can fail silently because there is no upgrade assessment available when performing this standalone upgrade to VCF Operations 9.0.x outside of Fleet Manager or LCM. The upgrade may then become stuck in a state that you cannot manually cancel via the UI. This is why it is always important to take backups and snapshots.

If the admin account is inaccessible due to failed login attempts to the standard UI  and/or adminUI, and root credentials on secondary nodes are expired or invalid, reference:

Aria Operations admin account getting locked even after password reset

Upgrade to Aria Operations 8.x fails due to the admin or root account password

How to Reset the Root Password for Aria Operations