Backup over FTP and SCP failed following upgrade to Messaging Gateway 10.9.2
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Backup over FTP and SCP failed following upgrade to Messaging Gateway 10.9.2

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Article ID: 430589

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Following the upgrade to Messaging Gateway 10.9.2 attempts to perform a backup using FTP or SCP fails with an authentication error:

FTP:Can't log in: Login incorrect. ERROR: Unable to send to the specified URL.

Scheduled backups fail with the following errors in the BrightmailLog.log:

Feb 19 2026 23:00:03 [BrightmailScheduler_Worker-25] [ScriptHelper] ERROR - Cannot backup the database. 
Feb 19 2026 23:00:03 [BrightmailScheduler_Worker-25] [ScriptHelper] ERROR - FTP:Can't log in: Login or password incorrect!ERROR: Unable to send to the specified URL. 
Feb 19 2026 23:00:03 [BrightmailScheduler_Worker-25] [ScheduledBackupTask] ERROR - Error occurred while attempting to execute scheduled backup. 
com.symantec.smg.controlcenter.BrightmailException
 at com.symantec.smg.controlcenter.agent.ScriptHelper.generateError(ScriptHelper.java:2779)
 at com.symantec.smg.controlcenter.disasterrecovery.backup.BackupManager.backupNow(BackupManager.java:325)
 at com.symantec.smg.controlcenter.disasterrecovery.backup.scheduled.ScheduledBackupTask.executeTask(ScheduledBackupTask.java:123)
 at com.symantec.smg.controlcenter.internal.scheduledtask.ScheduledTask.execute(ScheduledTask.java:133)
 at org.quartz.core.JobRunShell.run(JobRunShell.java:195)
 at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)

Cause

Changes to the remote backup to allow the '@' character in user names caused problems for FTP and SCP authentication for usernames without an @ sign.

Resolution

This issue is addressed by installing patch 10.9.2-299.

  1. Log into the SMG command line as admin
  2. Run
    patch -p 10.9.2-299 install
  3. Restart the Control Center web application service
    service controlcenter restart

Additional Information