Backup fails with "No space left on device" error
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Backup fails with "No space left on device" error

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Article ID: 429898

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Updated On:

Products

Messaging Gateway

Issue/Introduction

When attempting to back up the Messaging Gateway (SMG) Control Center database the backup fails and the BrightmailLog.log file shows the following error:

Nov 19 2025 02:04:57 [BrightmailScheduler_Worker-26] [ScriptHelper] ERROR - ERROR: Failed to run: '/opt/Symantec/Brightmail/mysql/bin/mysqldump': mysqldump: Couldn't execute 'SELECT TRIGGER_NAME FROM INFORMATION_SCHEMA.TRIGGERS WHERE EVENT_OBJECT_SCHEMA = DATABASE() AND EVENT_OBJECT_TABLE = 'log'': Disk full (/data/tmp/#sql-temptable-4e9-529-2c8.MAI); waiting for someone to free some space... (errno: 28 "No space left on device") (1021) 

The BrightmailLog.log also shows the following error when attempting to insert log data into the Control Center database:

Nov 19 2025 02:05:56 [LogAgentTask_6] [LogManager] ERROR - com.symantec.smg.controlcenter.internal.dataaccess.DataAccessException: An unexpected database error has occurred. Please contact your system administrator. ; nested exception is: 
     java.sql.SQLException: (conn=1307) Disk is full writing './brightmail/log.MYD' (Errcode: 28 "No space left on device"). Waiting for someone to free space... (Expect up to 60 secs delay for the server to continue after freeing disk space)

Cause

The log table in the Control Center database is full and cannot be expanded because there is insufficient disk space to increase the size of the database table file. This is commonly caused by having increased the Database Log Storage Limits well beyond the default values.

Resolution

To address this issue the amount of log data stored in the database will need to be reduced and the old data expunged.

  1. Log into the Control Center as an administrator
  2. Go to Administration > Logs
  3. Reset the Database Log Storage Limits to the default values:
    Maximum Log Size: 50MB
    Days to store log data before deleting: 7

Note:

  • The extra log data will not be removed until the next scheduled log expunger task which is usualy once per day at 2am.
  • The log expunger frequency can be temprarily reset to every hour to expunge the old data more quickly
  • The database log table file size will not be reduced until the next automatic database cleanup with usually runs at approximately 2am every day

If extended log retention is required, Broadcom suggests logging remotely via syslog to a log server or SIEM.

Additional Information