Reputation Sync Errors Due to SecurityToken Expired
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Reputation Sync Errors Due to SecurityToken Expired

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Article ID: 429723

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

  • App Control Server is not syncing with Reputation backend.
  • Historical Server Logs show errors in the ReporterLog-TIMESTAMP similar to
    ERROR TaskExecuter              - Reset attempt 2/10 of Carbon Black File Reputation connection after error: WSE511: It is invalid to use the security token SecurityToken-48b8d18e-1cd9-4347-90fb-21d5f31a12c0 now because the token is either expired or postdated.

    ERROR DatabaseConnectionWrapper - Database connection failed. Further database connect errors will not be logged. Timeout expired.  The timeout period elapsed prior to obtaining a connection from the pool.  This may have occurred because all pooled connections were in use and max pool size was reached.

Environment

  • App Control Server: All Supported Versions

Cause

The App Control Server is checking for a certificate associated with the Reputation Service that has expired.

Resolution

Upgrade the App Control Server to one of the maintenance release versions, or higher.

  • If on 8.10.x > upgrade to 8.10.6, 8.11.4, or higher.
  • If on 8.11.x > upgrade to 8.11.4 or higher.

 

Additional Information