When trying to install a SRA, the SRM UI shows the error: Unable to retrieve pairs from extension server at https://SRM FQDN:443/drserver/vcdr/vmomi/sdk. Unable to connect to Site recovery Manager Server
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When trying to install a SRA, the SRM UI shows the error: Unable to retrieve pairs from extension server at https://SRM FQDN:443/drserver/vcdr/vmomi/sdk. Unable to connect to Site recovery Manager Server

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Article ID: 429531

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • SRM GUI shows the below error when trying to install SRA on it:

Unable to retrieve pairs from extension server at https://SRM FQDN:443/drserver/vcdr/vmomi/sdk. Unable to connect to Site recovery Manager Server at https://SRM FQDN:443/drserver/vcdr/vmomi/sdk Reason: Unexpected status code: 503

  • The SRA log partition is full:

root@srm [ ~ ]# df -h
Filesystem                      Size  Used Avail Use% Mounted on
devtmpfs                        4.0M     0  4.0M   0% /dev
tmpfs                           4.9G   44K  4.9G   1% /dev/shm
tmpfs                           2.0G  856K  2.0G   1% /run
tmpfs                           4.0M     0  4.0M   0% /sys/fs/cgroup
/dev/sda4                        14G  5.5G  7.4G  43% /
tmpfs                           4.9G  488K  4.9G   1% /tmp
/dev/sda2                       238M   36M  190M  16% /boot
/dev/mapper/support_vg-support  3.9G  555M  3.2G  15% /opt/vmware/support
/dev/loop0                      378M  358M     0 100% /opt/vmware/support/logs/srm/SRAs

Environment

VMware Site Recovery Manager 
VMware Live Site Recovery

Cause

The support disk is partitioned into lvm ext4 filesystem & is used to store the logs of VMware-related services. The mount point of the partition is "/opt/vmware/support"

Some SRAs (Storage Replication Adapter) lack an inbuilt log rotation & compression software or don't have a limit on the size of logs they produce. This will result in the unplanned failure of the SRM server services due to the lack of any space available on disk for the log files.

The vmware-dr.log will show the below error message at the time of SRA installation:

2026-02-13T13:35:11.101Z info vmware-dr[01859] [SRM@6876 sub=Storage] Command queryInfo's stdout:
--> [2026-02-13 13:35:10.875: [info] 'xsra.Program.parseXmlContent' /home/srm/sra-linux/Program.cs 29 sra-linux (Process id=17) (Thread id=1)]: Commence: parseXmlConten
t operation.
--> [2026-02-13 13:35:10.891: [verbose] 'xsra.Program.parseXmlContent' /home/srm/sra-linux/Program.cs 31 sra-linux (Process id=17) (Thread id=1)]: xml file: 'input-4ff4
981e-3cd3-4358-8031-8db4cc8bfdcf.xml'
--> [2026-02-13 13:35:10.917: [info] 'xsra.Program.parseXmlContent' /home/srm/sra-linux/Program.cs 168 sra-linux (Process id=17) (Thread id=1)]: Complete: parseXmlConte
nt operation.
--> [2026-02-13 13:35:10.918: [info] 'xsra.Program.Main' /home/srm/sra-linux/Program.cs 220 sra-linux (Process id=17) (Thread id=1)]: Commence: Main
--> No space left on device
-->
2026-02-13T13:35:11.101Z error vmware-dr[01859] [SRM@6876 sub=Storage] Command queryInfo's stderr:
--> sudo: setrlimit(RLIMIT_CORE): Operation not permitted

Resolution

Clear the older and unwanted log files from the /opt/vmware/support/logs/srm/SRAs directory.

This will clear the space and the utilization will be down post which the SRA installation should be successful without issues.

For future, configure log rotation on the SRM log files by following the below KB article:

SRM services stop due to unmanaged SRA log files