Tier-0 to uplink connectivity loss after upgrade when T0 uplink and Tier-1 service interface share the same VLAN segment.
search cancel

Tier-0 to uplink connectivity loss after upgrade when T0 uplink and Tier-1 service interface share the same VLAN segment.

book

Article ID: 429159

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

In some NSX environments, connectivity between Tier-0 and the uplink device can be lost, leading to an outage or severe slowness for workloads behind the Tier-0 VRF.

  • Loss or disruption of connectivity from Tier-0 to the uplink device.
  • Inability to ping the edge uplink interface IP from the same edge node.
  • Partial outage or noticeable slowness for workloads behind the Tier-0 VRF.
  • The same VLAN-backed logical segment is used for both:
        - a Tier-0 uplink interface  
        - a Tier-1 service (CSP) interface  
  • Both interfaces are on the same edge node (same Transport Node).

NOTE: Consider this issue if the environment was upgraded from NSX 3.1.x to 3.2.x or 4.x, and the same VLAN segment is used for both a T0 uplink and a T1 service interface on the same edge

Environment

VMware NSX-T 3.x

VMware NSX 4.1.x

Cause

Validation of 'two interfaces are connected to the same VLAN segment and both interfaces belong to the same edge VM' did not hit. 
During the UFO data migration upgrade, the logical router port relationship is not created properly with logical switch UUID.
Ideally the relationship should have been created as UUID based instead it might have been created with string id.

Resolution

This issue is resolved in VMware NSX 4.2.1.2, 4.2.2, 9.0, available at Broadcom downloads.
If you are having difficulty finding and downloading software, please review the Download Broadcom products and software  KB.

Workaround:
Do a simple update on the interfaces for both Tier0 & Tier1 (e.g. add some description).