Orchestrator tasks stuck in "Waiting for Input" cannot be cancelled
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Orchestrator tasks stuck in "Waiting for Input" cannot be cancelled

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Article ID: 428794

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Updated On:

Products

VCF Automation

Issue/Introduction

Symptoms:

  • one or multiple tasks are pending in the Orchestrator portal "Waiting for Input"
  • attempting to answer or cancel these task's does fail with error: "Failed to cancel workflow run with id: ###"
  • reviewing the workflow executions in tab "Workflow Runs" you are unable to find the workflow run for this time

Environment

Aria Automation Orchestrator

Cause

The root cause of this issue is an orphaned task entry in the database. The workflow execution (workflow token) associated with the "Waiting for Input" task is no longer available or has been purged from the Orchestrator engine. Because the system cannot locate the valid workflow token, it cannot process the command to update or terminate the task.

Resolution

If you experience this issue then please contact Broadcom Support and reference article number 428794.