When attempting to generate/download logs from the VAMI of a VCSA, the link expires before it can be collected immediately after collection.
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When attempting to generate/download logs from the VAMI of a VCSA, the link expires before it can be collected immediately after collection.

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Article ID: 428685

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When attempting to use the VAMI GUI of a VCSA to collect a log bundle, the bundle will collect, but the link will in some circumstances expire prior to the 12 hours expected.

Environment

VMware vCenter Server Appliance 8.x

Cause

By default VPXD periodically (every 30 minutes) cleans up support bundles and in some cases may delete the log bundle before it can be collected.

Resolution

Option 1

Collect logs from the vCenter GUI or VCSA CLI.

Collecting diagnostic information for VMware vCenter Server 7.x and 8.x

Option 2

If you wish to collect the logs from the VAMI and experience the issue, perform the following commands to allow the file to "linger" for a longer period of time:

1. Backup the current config:

# cp /etc/vmware-vpx/vpxd.cfg /etc/vmware-vpx/vpxd.cfg.bkp

2. Edit the /etc/vmware-vpx/vpxd.cfg file using VI: 

# vi /etc/vmware-vpx/vpxd.cfg

3.  Add the following under <config> section:

 <logBundler>
    <lingerPeriod> #Add_the_time_in_seconds </lingerPeriod>
 </logBundler>

Note:  Recommend setting this to 39600 which will equal 11 hours.

4.  Save the file after editing it:

:wq!

5.  Either perform a restart on the VCSA or restart all of the services:

# service-control --stop --all && service-control --start --all

6.  Test collecting a log bundle from the VAMI.

Additional Information

Collecting diagnostic information for VMware vCenter Server 7.x and 8.x