Database Cannot be Accessed During Upgrade Attempt
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Database Cannot be Accessed During Upgrade Attempt

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Article ID: 428468

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

When upgrading the App Control server, the following messages is displayed after accepting the license agreement. 

Carbon Black App Control database cannot be accessed.
Please verify your user credentials and try again. 

Environment

  • Carbon Black App Control Server: All Versions

Cause

Incorrect server name in the install.dsn or shepherd.dsn

Resolution

  1. Open the SQL Database in SQL Server Management Studio (SSMS)
  2. Check the Server Name being logged into. 
  3. Open these two files as an administrator. (Disable the App Control agent if installed)
    1. C:\Program Files (x86)\Bit9\Parity Server\install.dsn
    2. C:\Program Files (x86)\Bit9\Parity Server\shepherd.dsn
  4. Match the server= to the Server Name. 
    1. If the server name is Domain\SQLServer use "server=.\SQLServer"
    2. If the server name is SQLServer use "server=SQLServer"
  5. Save the files and attempt the upgrade again. 

Additional Information