VMware NSX Advanced Load Balancer Controller showing Cluster degraded in NSX-T UI
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VMware NSX Advanced Load Balancer Controller showing Cluster degraded in NSX-T UI

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Article ID: 427081

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The issue is seen with environment running VMware NSX and NSX Advanced Load Balancer (ALB).
  • Post upgrade of NSX-T or back up from configuration, the ALB is no longer visible in the NSX-T UI, however, the communication between the NSX Manager and ALB works fine.
  • The Virtual IP address under NSX Load balance does shows correctly.
  • The error message observed within the NSX UI is "Avi Load Balancer Cluster Degraded"

Environment

  • VMware NSX
  • VMware NSX Advanced Load Balancer

Cause

  • This issue is caused by missing entries in the 'AlbControllerNodeVmDeploymentRealTimeInfo table' within the Deploymentunit database. This data gap prevents the NSX manager to show the AVI ALB in the NSX-T UI.

Resolution

  • Please collect the 'deployment unit & ALB' script along with the NSX Manager support bundle. These diagnostics will be needed to validate the environment before opening an internal task to perform manual modifications within the CorfuDB.
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t AlbControllerNodeVmClusterConfig >> cluster.dump
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t AlbControllerNodeVmDeploymentRequest >> deploymentReq.dump
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t AlbControllerNodeVmDeploymentRealTimeInfo >> albRealtime.dump
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t ALBControllerAdminCreds >> albcreds.dump
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t EnforcementPoint >> ep.dump
    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t DeploymentUnit
  • Once the table output has been collected, please share it with the the Assigned Engineer to get the consolidated script approved by the internal team. This script must be executed on the specific NSX Manager currently holding the Virtual IP (VIP)
  • Post running the script given by Engineering in step 2, please restart the Proton service and check the status.

    > service proton restart
    > service proton status
  • Once the proton service is up, please verify the table with the below script.

    /opt/vmware/bin/corfu_tool_runner.py -o showTable -n nsx -t AlbControllerNodeVmDeploymentRealTimeInfo

     

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • Ensure log date range covers the full date of the event(s) being investigated. When in doubt, retrieve logs for all time.
  • NSX Manager log bundles
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation

Handling Log Bundles for offline review with Broadcom support